Documentation Home Page ◇ RT-LAB Home Page
Pour la documentation en FRANÇAIS, utilisez l'outil de traduction de votre navigateur Chrome, Edge ou Safari. Voir un exemple.
Preference Pages
- 1 Capabilities Preference Page
- 2 Compiler and Linker Preference Page
- 3 Monitoring Preference Page
- 4 Debugging Preference Page
- 5 Environment Variables Preference Page
- 6 Files Transfers Preference Page
- 7 Performance Preference Page
- 8 Real-time Preference Page
- 9 Hardware Preference Page
- 10 Simulation Tools Preference Page
- 11 MATLAB Preference Page
- 12 RT-LAB Preference Page
- 13 Target Detection Preference Page
- 14 Accessibility Preference Page
- 15 Annotations Preference Page
- 16 Capabilities Preference Page
- 17 Appearance Preference Page
- 18 Colors and Fonts Preference Page
- 19 Compare/Patch Preference Page
- 19.1 General Options
- 19.1.1 Text Compare Options
- 19.1.2 Content Types Preference Page
- 19.1.3 Editors preference page
- 19.1.4 File Associations Preference Page
- 19.1.5 Help Preferences
- 19.1.6 General Preference Page
- 19.1.7 Help Content Preference Page
- 19.1 General Options
- 20 Keys Preference Page
- 21 Keystrokes, Key Sequences, and Key Bindings
- 22 Cheat Sheets
- 22.1 MetaController
Use the Window > Preferences dialog page to set the preferences of RT-LAB.
The value of these parameters are used when a new model is created. If you change a property from the Preference page, each new model will inherit settings from the Properties defined in the Preference page but existing models stay unchanged.
Capabilities Preference Page
Window > Preferences > RT-LAB > Capabilities
The capabilities preference page allows you to enable or disable various product components of RT-LAB such as Operator or Developer environments. By default, no capabilities are active and only the basic functionalities of RT-LAB are active.
Operator | This capability enables all features that allow the user to manage consoles and make some changes to the parameters and aliases of the models. It enables all components making data acquisition and monitoring and also basic operations on the simulator as loading, executing, pausing or resetting the models. (default value=false) |
|---|---|
Developer | This capability enables all features related to the development of models, scripts, and codes. It also enables all features of the operator capabilities. (default value=false) |
Advanced User | This capability enables all product components including operator and developer capabilities. Moreover, it also enables other unclassified features related to Eclipse and external plugins. (default value=false) |
Compiler and Linker Preference Page
Window > Preferences > RT-LAB > Development > Compiler
The value of these parameters is used when a new model is created. If you change a property from Preference page, each new model inherits settings from Properties defined in the Preference page but the existing models stay unchanged.
The Restore Defaults button | Enables the user to restore the defaults value of the parameters. |
|---|---|
Sources | Names of source files to be compiled in addition to the code generated by RTW. Used to incorporate user-written code into the model executable (e.g. file1.c file2.c file3.c) |
Includes | Target path(s) where user include files can be found. Used to search for include files required to compile user-written code, when the include files do not reside in already-searched paths. |
Libraries | Names of user-specified libraries to be used when incorporating user-written code, in addition to the standard system libraries (MATLAB and RT-LAB). |
Library path | Target path(s) where user libraries can be found. Used to search for libraries other than the MATLAB and RT-LAB libraries when incorporating user-written code. |
Compiler command | User command to be called on the target during the compilation process. |
Monitoring Preference Page
Window > Preferences > RT-LAB > Diagnostic > Monitoring
The value of these parameters is used when a new model is created. If you change a property from Preference page, each new model will inherit from Properties defined into Preference page but the existing models will stay unchanged.
Enable monitoring | Enables or disables the monitoring during the execution of the model. (default value=true) |
|---|---|
Display controller in operating system task bar | Displays RT-LAB Controller application in the taskbar. Unchecked by default. (default value=false) |
Display warning when disk space is lower than [Mo] | When checked, a warning message is displayed when the disk space is lower than the value specified. (default value=false) |
Target display information | Represents the amount of information that is displayed in the display window during load and execution. Setting the value from MINIMAL to EXHAUSTIVE allows the user to retrieve more information about communication and I/Os initialization for example. This can be used to debug unexpected model behaviors. (default value=minimal) |
Message precision factor (us) | Defines the precision of the timer reporting the time required to perform one calculation step in microseconds. The default value is 0 (no printout). Value=1 prints the step size of the model every 1,000,000 steps with a precision of 1 μs. Value=100 prints the model’s step size every 10,000 steps with a precision of 100 μs and so on. (default value=0) |
Debugging Preference Page
Window > Preferences > RT-LAB > Diagnostic > Debugging
The value of these parameters are used when a new model is created. If you change a property from Preference page, each new model will inherit from Properties defined into Preference page but the existing models will stay unchanged.
Enable controller log (s) | Creates a file called Controller.log in the RTLAB_ROOT\common\bin folder for debugging use. This file reports all operations perform on the model during the life-cycle of your project. Note also that it reports also other internal operation related to the controller of your project. Unchecked by default. (default value=false) |
|---|---|
Enable extended timeout | All timeouts are extended when this option is enabled. It is typically used when debugging the model. (default value=false) |
Enable watchdog | Enables or disables the Watchdog functionality. The Watchdog ensures that all nodes are running normally. There are as many watchdogs as there as computation subsystems in the model. At regular user-defined time intervals, the watchdog verifies that the model is still running and that processes are still active. If an error occurs, the watchdog stops the simulation. This option is not available on Windows target.(default value=true) |
Watchdog timeout [ms] | The regular user-defined time interval the watchdog verifies the model is still running. 5000 ms by default. (default value=5000) |
Compile model in debug | When this option is enabled, the compiler's optimization options are removed and replaced by debug options during model compilation. This option is useful when debugging a model. (default value=false) |
Environment Variables Preference Page
Window > Preferences > RT-LAB > Execution > Environment Variables
The value of these parameters are used when a new model is created. If you change a property from Preference page, each new model will inherit from Properties defined into Preference page but the existing models will stay unchanged.
Name | Name of the user variable. |
|---|---|
Value | Value of the user variable. |
Description | Description of the user variable. |
Files Transfers Preference Page
Window > Preferences > RT-LAB > Execution > File
The value of these parameters is used when a new model is created. If you change a property from Preference page, each new model will inherit from Properties defined into Preference page but the existing models will stay unchanged.
File retrieval root directory | Directory where the files retrieved by RT-LAB after the model execution is copied. |
|---|---|
Enable automatic file retrieval | When this option is enabled, RT-LAB retrieves files generated by the model simulation on the target nodes and transfers them to the host computer. (default value=true) |
Enable file retrieval during simulation | If this option is enabled, RT-LAB retrieves the files |
Build intermediate tree on file retrieval | Specifies if intermediate folders are generated or not in the retrieved directory. (default value=true) |
Display notifications | Displays a pop-up notification each time a file is retrieved: Clicking on the notification opens the file with an appropriate editor or with Matlab, depending on the file extension. |
Do not display notifications at reset | Prevents RT-LAB from displaying notifications when files are retrieved after a model has been reset. This is useful when many files are retrieved, since there is one notification per file. |
Performance Preference Page
Window > Preferences > RT-LAB > Execution > Performance
The value of these parameters are used when a new model is created. If you change a property from Preference page, each new model will inherit from Properties defined into Preference page but the existing models will stay unchanged.
Enable detection of overruns | (Only applies to models ran in hardware/software synchronized modes.) When this parameter is not checked, RT-LAB does not detect overruns. When this parameter is checked, RT-LAB detects overruns and performs the action specified in the Action to perform on overruns field. This property has no effect in simulation mode. (default value=true) | ||||||||
|---|---|---|---|---|---|---|---|---|---|
Perform action after N overruns | Performs the action specified in the Action to perform on overruns field when the number of overruns detected by RT-LAB reaches this number. (Only applies when Action to perform on overruns is set to Reset or Pause.) Default value=10 | ||||||||
Action to perform on overruns | Type of action to perform when overruns are detected. Default value=Continue Here are the available types:
|
Real-time Preference Page
Window > Preferences > RT-LAB > Execution > Real-Time
The value of these parameters are used when a new model is created. If you change a property from the Preferences page, each new model inherits from Properties defined in the Preference page but the existing models stay unchanged.
Default target Platform | Allows the user to choose the target platform on which to run the simulation (OPAL-RTLinux (x86-based) or Windows system). Default value=OPAL-RTLinux x86-based. |
|---|---|
Real-time simulation mode | Enables the user to define how the model’s simulation can be executed on an OPAL-RTLinux (x86-based) or Windows system. Default value=Software synchronized. |
Simulation | In this mode, the model is not synchronized; the model starts a new computation step as soon as the previous one is completed (the model runs as fast as possible). |
Simulation with low priority | this simulation mode can be used to run a simulation in the background while working with other applications on the same computer. |
Note: 'Simulation with low priority' mode is only available when working with a Windows target. | |
Software Synchronized | In this mode, real-time synchronization of the entire simulation is achieved by the OS, using the CPU clock as a reference. Depending on the resolution available on the OS, some sampling times may not be obtained using this mode. |
Hardware Synchronized | In this mode, an I/O board clock is used to synchronize the entire simulation. |
Real-time communication link type | Sets the target cluster’s communication medium. Default value=UDP/IP. Here are the available choices for each target platform.
|
Time Factor: | This value, when multiplied by the model’s basic calculation step (or fixed step size), supplies the final calculation step for the system. The time factor can only be changed when the simulation execution is paused and is only available in Synchronized (hardware/software) mode. |
Note: This parameter enables you to change the I/O acquisition speed. Because the model always uses the basic calculation step, changing the time factor for the I/O may give results that differ from the offline simulation. This parameter should be used only to determine the simulation’s minimum calculation step. Once this step is determined, this parameter must be brought back to a value of 1. The model’s basic calculation step must be updated accordingly by setting the correct value in the Simulink model and by recompiling it. | |
Stop time | This value (in seconds) specifies when the model will stop. If the value is Infinity, the model executes forever. You don’t need to recompile the model to apply a new value. (default value=Infinity) |
Pause time | This value (in seconds) specifies when the model will pause. If the value is Infinity, the model executes until a reset is done except if a stop time is specified. (default value=Infinity) |
Hardware Preference Page
Window > Preferences > RT-LAB > Hardware
The values of these parameters are used when a new model is created. If you change a property from the Preferences page, each new model inherits from Properties defined into Preference page but the existing models will stay unchanged.
Reset model on I/O board missing | When the option is checked and the model is loaded, RT-LAB stops loading and generates an error, if some I/O boards required by the model are not detected on the target(s). RT-LAB generates only a warning if this setting is unchecked. Note that only a few I/O boards (mainly the Opal-RT TestDrive boards) support this option. Most I/O blocks force a reset of the model if the boards are not detected at load time. Default value=true. |
|---|---|
Abort compilation on bitstream missing | When option is enabled, if some bitstreams required by a model are not present in the model directory, RT-LAB stops the compilation and generates an error. RT-LAB generates only a warning if this setting is disabled. Default value=false. |
Simulation Tools Preference Page
Window > Preferences > RT-LAB > Simulation Tools
The value of these parameters are used when a new model is created. If you change a property from Preference page, each new model inherits from Properties defined in the Preference page but the existing models stay unchanged.
Matlab command before opening model | Matlab command to execute before opening the model. For example. MyInitFile.m, where MyInitFile includes commands that initialize model variables. |
|---|---|
Matlab command after opening model | Matlab command to execute after opening the model. For example, MyInitFile.m, where MyInitFile includes commands that initialize model variables. |
Handle console automatically | Enables the console to be automatically opened and closed, when a model is Loaded or Reset. The console starts automatically at the first model’s execution. Default |
MATLAB Preference Page
Window > Preferences > RT-LAB > Simulation Tools > Matlab
The value of these parameters are used when a new model is created. If you change a property from Preference page, each new model inherits Properties defined in Preference page but the existing models stay unchanged.
Use same Matlab version than model | Use same Matlab version as model to open and compile Simulink mode. If Matlab version of model is not supported or not installed, use Current Matlab version. Default value=unchecked. Note: In an opened project, if a model is saved in a new Matlab version, the new Matlab version will be used next time your project is opened. |
|---|---|
Current Matlab version | Matlab version used to open and compile Simulink models. Note: this setting will be changed if the user opens the model by choosing Edit with and a new Matlab version. Default value is the latest installed, compatible version |
Matlab and Simulink target root directory | Path to be used instead of /usr/matlab to find the MATLAB include and source files. RT-LAB supports multiple versions of Matlab by keeping copies of previous versions in paths other than /usr/matlab. Automatic setting means the target path is |
RTW template make file (TMF) | Specifies which template makefile to use during the compilation. When Automatic is selected, the template makefile corresponding to MATLAB version is automatically selected. This option is available for SIMULINK models only. (default value=automatic) |
RTW target language compiler file (TLC) | Specifies which TLC file to use during the compilation. When Automatic is selected, the TLC file corresponding to the MATLAB version is automatically selected. This option is available for SIMULINK models only. (default value=automatic) |
RT-LAB Preference Page
Window > Preferences > RT-LAB > Simulation Tools > RT-LAB
The value of these parameters is used when a new model is created. If you change a property from the Preference page, each new model inherits from Properties defined in the Preference page but the existing models stay unchanged.
Development targets OPAL-RTLinux (x86-based) | Identifies the target node where the compilation is done. Target nodes must be defined in the workbench, by using the New Target wizard, before the development node can be chosen. |
|---|---|
Target root directory | Path to find the RT-LAB executables include files and libraries or the target nodes. This allows previous versions of RT-LAB to be used side-by-side with newer versions. Automatic setting means the target path is automatically set based on the last installed RT-LAB version. (default value=Automatic) |
Target Detection Preference Page
Window > Preferences > RT-LAB > Target Detection
Enable target detection | Uncheck this option to completely disable automatic target detection. Target detection can still be manually done by right-clicking on the Targets item of the Project Explorer and selecting the Discover targets menu. |
|---|---|
Display notifications | Displays a popup notification each time a target is detected: Clicking on the notification opens the Detected Targets Wizard. Automatically add new targets to the workbench: New targets are added to the workbench as soon as they are detected. |
Ignored targets | If you do not want to be notified when a particular target is connected to the network, simply add its IP address to this table. This table is also automatically populated by the Detected Targets Wizard. |
Detection ranges | Here you can limit the target detection to some IP addresses by defining ranges. Any target outside these ranges will not be detected by RT-LAB. |
General Preferences Pages: Window > Preferences
Accessibility Preference Page
General > Editors > Text Editors > Accessibility
Use custom caret | Replaces the original caret (the marker that indicates where the next character will appear) with a custom caret and shows a different caret for Overwrite and Insert modes. |
|---|---|
Enable thick caret | Replaces the original caret with a more visible, thicker caret. |
Use characters to show changes on line number bar | Quick Diff shows the changes in a vertical ruler using colors. Color-blind persons can enable this option to show differences with different characters in the line number ruler. |
Annotations Preference Page
General > Editors > Text Editors > Annotations
Show in Text as | The selected annotation type is shown in the text. The corresponding text is underlined with squiggles or highlighted. |
|---|---|
Show in Overview ruler | The overview ruler on the right side of the text editor is shown. |
Show in Vertical ruler | The selected annotation type is shown in the vertical ruler. |
Color | The color for the selected annotation type. |
Capabilities Preference Page
The capabilities preference page enables or disables various product components of RT-LAB such as Operator or Developer environments. By default, no capabilities are active and only the basic functionalities of RT-LAB are active.
Note: Some capability selections have dependencies on other capabilities, disabling a required capability while leaving dependant capabilities enabled only results in them becoming re-enabled.
RT-LAB | Enables all features related to RT-LAB. Do not disable this capability. |
|---|---|
RT-LAB Operator | Enables all features allowing the user to manage consoles and make changes to the parameters and aliases of the models. It enables all components to perform data acquisition and monitoring and also basic operations on the simulator as loading, executing, pausing or resetting the models. (default value=false) |
RT-LAB Developer | Enables all features related to the development of models, scripts, and codes. It also enables all features of the operator capabilities. (default value=false) |
RT-LAB Advanced User | Enables all product components including operator and developer capabilities. Moreover, it also enables other unclassified features related to Eclipse and external plugins. (default value=false) |
Development | Use the Eclipse SDK to develop applications. |
Team | Use configuration management systems to manage resources. |
Appearance Preference Page
General > Appearance
Current presentation | Specify the currently active presentation (look and feel). |
|---|---|
Override presentation settings | Locally override the settings from the current presentation's defaults. |
Editor tab positions | Specify either top or bottom to indicate where you want tabs for stacked editors to appear. |
View tab positions | Specify either top or bottom to indicate where you want tabs for stacked views to appear. |
Perspective switcher positions | Specify the location of the perspective switcher bar. |
Current theme | Specify the currently active theme (color and font set). |
Show text on perspective bar | Specify whether labels should be shown in the perspective bar as well as icons. |
Show traditional style tabs | Specify whether traditional (square) tabs should be used in place of the curved tabs. |
Enable animations | Enable/disable the feature where views animate to their location when closed or opened. |
Colors and Fonts Preference Page
General > Appearance > Colors and Fonts
A tree is used to navigate among and show a short preview of the various colors and fonts.
The current face (but not size) of any font is previewed in its label. Colors are previewed in the icon associated with its label. Additionally, some categories (Workbench in particular) provide a more detailed preview of their contributions. This preview is shown below the description area if available. Font settings can be changed either by selecting the font from the list and clicking Use System Font to choose the Operating System font setting or by clicking Change to open up a font selection dialog. Color settings can be changed by clicking color to the right of the tree area when a color is selected.
The Colors and Fonts text field can be used to filter the contents. Simply type in an entry and any matching results will remain in the tree view.
Descriptions and previews are provided when the Workbench colors and font settings are selected.
Compare/Patch Preference Page
General > Compare/Patch
General Options
Open structure compare automatically | This option controls whether a structure compare is automatically performed whenever a content compare is done. Turn this option off if you don't want to see the structural differences. |
|---|---|
Show structure compare in Outline view when possible | If on, structure compare is displayed in the Outline view whenever it is possible. |
Show additional compare information in the status line | If on, additional information about a change is shown in the status line. Turn this option on if you are interested in additional information about a change. |
Ignore white space | Controls whether or not whitespace change are shown in the compare viewer. Turn this option on if you want to see changes in whitespace. |
Automatically save dirty editors before browsing patches | Controls whether any unsaved changes are automatically saved before a patch is applied. Turn this option on if you want to save changes automatically. |
Filtered Members |
Note: The names in the list must be separated by a comma. |
Text Compare Options
Synchronize scrolling between panes in compare viewers | The two comparison viewers will lock scroll along with one another in order to keep identical and corresponding portions of the code in each pane side-by-side. Turn this option off if you do not want the compare viewers to lock scroll. |
|---|---|
Initially show ancestor pane | Sometimes you want to compare two versions of a resource with the previous version from which they were both derived. This is called their common ancestor, and it appears in its own comparison pane during a three-way compare. Turn this option on if you want the ancestor pane to always appear at the start of a comparison. |
Show pseudo conflicts | Displays pseudo conflicts, which occur when two developers make the same change (for example, both add or remove the exact same line of code or comment). Turn this option on if you want pseudo conflicts to appear in compare browsers. |
Connect ranges with single line | Controls whether differing ranges are visually connected by a single line or a range delimited by two lines. |
Highlight individual changes | Controls whether the individual changes inside conflicts are highlighted. |
When the end/beginning is reached while navigating an element | Use this option to configure what occurs when the end/beginning is reached while navigating an element. |
Prompt | If this option is on and you selected to compare a single element you will be asked whether you want to go to the beginning/end of the element after the end/beginning is reached. If you are comparing two or more elements you will be asked whether you want to go to the beginning/end of the current element or to go to the next/previous element. Moreover, if you choose to remember your decision, this option will be changed to one of the below respectively. |
Loop back to the beginning/end | When this option is on, the selection will be moved back to the beginning/end after you reach the end/beginning of an element. |
Go to the next/previous element | If you are comparing two or more elements and this option is on after you reach the end/beginning of an element the next/previous element will be opened. |
Content Types Preference Page
The General > Content Types preference page enables you to edit content types and their associated file names and character sets. You can also associate arbitrary file names or file extensions with content types. A content type acts as a description of a certain class of files (for instance, XML files). RT-LAB uses this description in various scenarios, such as editor look-ups and file comparisons.
Window > Preferences > General > Content Types
By selecting a content type in the topmost tree, you can alter the file names and extensions associated with it.
Note: Certain items are marked as locked. An item is locked if it is one of the associations provided by the plug-in that declares the content type. In other words, you can remove only user-contributed associations.
Adding an association is as simple as clicking Add.... A dialog prompts you to enter the file name or extension.
In addition to adding and removing file names or extensions, you can also set the default encoding for a given content type. To do this, simply enter the encoding name in the provided field and click Update.
Editors preference page
General > Editors